Skip to content

guifi.net – notícies guifi.net 1970-01-01 00:00:00

n/d

Zarabanda

Esta noche un post cultural sobre música ;) Estaba escuchando algo de música y ha caído la conocidisima Zarabanda de Haëndel, fijo que la habréis oído mil veces


Handel – Sarabande

Pero ¿de dónde sale la Zarabanda? pues su orígen no es muy claro, se dice que tiene orígenes panameños (ya que es la primera datación que se tiene de su referencia), pero se dice que se popularizó ahí pero su orígen era Español y fue introducido por los moriscos. Inicialmente era reproducido con guitarra española. Se prohibió su reproducción en 1583 por ser obsceno y despreciable bajo pena de doscientos azotes y seis años de galeras para los hombres y destierro del reino para las mujeres.
En el barroco (del 1600 a alrededor de los 1750), se bajó el ritmo y se usó como música de cambra y se incluyó en el círculo de música culta de la época (vaya tumbos! :P)
Más adelante se ha mencionado éste estilo de música en la literatura española.

Las zarabandas se fueron popularizando por todo Europa, sobretodo Italia, Francia e Inglaterra


Canarios

Igualita que la del Barroco ¿no? ;) Aunque los canarios parece que fue un baile similar al de las Zarabandas, pero la notación de la música es similar.

Si hay alguien mas entendido que yo en éste tema, que me disculpe :P… ||| Seguir leyendo... >>>

Xerrada de Guifi.net a l’Estartit (Baix Empordà)

24/07/2015 19:00
24/07/2015 20:00
Europa/Andorra
24/07/2015 19:00
24/07/2015 20:00
Europa/Andorra

Farem una trobada i posada en comú d'usuaris de guifi.net a l'Entitat Municipal descentralitzada de l'Estartit (EMD).

Xerraires (guifaires): pitupla & jmsola1sergigarcia

  • Farem una mica de xerrada i explicació de guifi per els nous usuaris de l'Estartit i pobles veïns que vindran a coneixer el projecte
  • Presentació dels nous serveis (ftp, proxy, VeuIP, ..) que hi ha disponibles a la zona
  • Propostes i coses cal fer a la zona
  • Dubtes i preguntes

Com arribar-hi: https://goo.gl/maps/Q6yhb

Tothom hi serà benvingut!

Flyer xerrada

 

Proteger un router Mikrotik expuesto a internet

Cuidadín con la regla que apliqué el otro día, que lo hace demasiado bien y no deja pasar absolutamente ninguna petición de DNS :P

Aquí os dejo 3 protecciones interesantes.

Protección del login ssh

/ip firewall filter
add action=drop chain=input comment="BLOQUEJA DURANT 24 hores qui fa 5 intents seguits de login SSH!" dst-port=22 protocol=tcp src-address-list=black_list_ssh
add action=add-src-to-address-list address-list=black_list_ssh address-list-timeout=1d chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=
    ssh_stage4
add action=add-src-to-address-list address-list=ssh_stage4 address-list-timeout=1m chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=
    ssh_stage3
add action=add-src-to-address-list address-list=ssh_stage3 address-list-timeout=1m chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=
    ssh_stage2
add action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m chain=input connection-state=new dst-port=22 protocol=tcp src-address-list=
    ssh_stage1
add action=add-src-to-address-list address-list=ssh_stage1 address-list-timeout=1m chain=input connection-state=new dst-port=22 protocol=tcp

Protege los intentos de login al 8291 (winbox)

/ip firewall filter
add action=drop chain=input comment="BLOQUEJA DURANT 24 hores qui fa 5 intents seguits de login winbox!" dst-port=8291 protocol=tcp src-address-list=
    black_list_winbox
add action=add-src-to-address-list address-list=black_list_winbox address-list-timeout=1d chain=input connection-state=new dst-port=8291 protocol=tcp 
    src-address-list=winbox_stage4
add action=add-src-to-address-list address-list=winbox_stage4 address-list-timeout=3m chain=input connection-state=new dst-port=8291 protocol=tcp src-address-list=
    winbox_stage3
add action=add-src-to-address-list address-list=winbox_stage3 address-list-timeout=3m chain=input connection-state=new dst-port=8291 protocol=tcp src-address-list=
    winbox_stage2
add action=add-src-to-address-list address-list=winbox_stage2 address-list-timeout=3m chain=input connection-state=new dst-port=8291 protocol=tcp src-address-list=
    winbox_stage1
add action=add-src-to-address-list address-list=winbox_stage1 address-list-timeout=3m chain=input connection-state=new dst-port=8291 protocol=tcp

Proteger de ataques de DoS (denegación de servicio)

add action=jump chain=forward connection-state=new jump-target=detect-ddos
add action=return chain=detect-ddos dst-limit=32,32,src-and-dst-addresses/10s
add action=return chain=detect-ddos src-address=192.168.0.0/16
add action=add-dst-to-address-list address-list=ddosed address-list-timeout=10m chain=detect-ddos
add action=add-src-to-address-list address-list=ddoser address-list-timeout=10m chain=detect-ddos
add action=drop chain=forward connection-state=new dst-address-list=ddosed src-address-list=ddoser
||| Seguir leyendo... >>>

Icedove: reply on top

Primero de todo me protejo del ataque masivo de frutas y hortalizas podridas… si… aquí cuento como hacer top-posting en los mails!

La cosa es que muchas veces tengo que responder mails y la firma se me queda al pie, así que tengo que ir a buscarla al pie del mail, cortarla y luego pegarla donde quiero… y esto a lo largo de la semana son unos cuantos minutos hahaha.

La solución es ir a la configuración avanzada de icedove (Editar Preferencias Avanzado General Editor de configuración) y cambiar el valor de mail.identity.default.sig_bottom que está a true a false (o viceversa).

Si tienes varias cuentas, cambias el default por id1, id2, id3, lo que sea y cambias el comportamiento de la variable.

Y voilà! :)… ||| Seguir leyendo... >>>

Cómo organizar un evento: Summer Camp Garrotxa

Hace mogollón de años que organizo cosas, primero en el instituto (1999) fiestas, cenas y demás movidas, después con els diables los correfocs, en la que teníamos que pedir dinero a los ayuntamientos, contactar con los otros grupos, hacer difusión, comprar la pirotecnia, montar el correfoc y finalmente hacer la cena.
Mi etapa en el instituto las fiestas grandes de mas de 1000 asistentes simplemente estaba de colaboradora, no de coordinadora, pero en las cenas de clase y los correfocs si que tuve ya el rol de coordinadora, las movidas iban de los 30 a las 150 personas, por supuesto cuando estás organizando cosas así es clave tener el sitio, saber la gente que vaya a venir y por supuesto que salgan los números. Estas movidas normalmente duraban unas horas, pero hace 7 años (2008) se me ocurrió meterme en un berenjenal mas bestia, el de montar un evento de 3 días, en medio de la nada!

Año tras año he ido adquiriendo experiencia, he ido aprendiendo de mis errores, avanzandome a los imprevistos y mejorando la forma de organizar y coordinar los eventos, este año 2015, todo el mundo coincide en que la organización ha ido como un reloj suizo! :) es bueno que la gente tenga esta impresión, pero si somos perfeccionistas hay cosas a mejorar :P

Algunas personas cercanas me han pedido que haga un howto summercamp garrotxa, así que aquí publico algunas de las cosas que se tienen que tener en cuenta y también cosas que … ||| Seguir leyendo... >>>

Mitigar ataque de DNS con mikrotik

/ip firewall filter
add action=drop chain=forward comment="drop from all in dns-flood address list" dst-port=53 protocol=udp src-address-list=dns-flood
add chain=forward comment="add src IP to dns-flood address list" dst-limit=1,10,src-address/20s dst-port=53 protocol=udp           
add action=add-src-to-address-list address-list=dns-flood address-list-timeout=23h59m59s chain=forward dst-port=53 protocol=udp    
||| Seguir leyendo... >>>

Script para hacer backups de los router mikrotik

Pues aquí una pequeña ayuda :)

#!/bin/bash

############################################
# SCRIPT CREATED BY: Laura Mora i Aubert   #
# SCRIPT DATE: 2015-07-05                  #
# WEBSITE: http://blackhold.nusepas.com    #
# INFO: Script that allows remote backup   #
#       of Mikrotik Routers.               #
#       tested on 5.x & 6.x routers        #
# LICENSE: creative commons (by:sa)        #
############################################

############################################
#             INSTRUCTIONS                 #
############################################
#                                          #
# 1. Generate ssh-keys on your server      #
#      cd ~/.ssh                           #
#      sh-keygen -t dsa                    #
#                                          #
# 2. Rename pubkey                         #
#      cp .ssh/id_dsa.pub backupkey        #
#                                          #
# 3. Put the file on MKT Router            #
#      ftp x.x.x.x                         #
#      ftpbin                            #
#      ftpput backupkey                  #
#      ftpbye                            #
#                                          #
# 4. Import pubkey in MKT Router           #
#      telnet x.x.x.x                      #
#      [admin@mikrotik] /user ssh-keys    #
#       import user=admin                 #
#       public-key-file=backupkey          #
#                                          #
# 5. Access with ssh to the MKT Router     #
#                                          #
# 6. [SCRIPT] Change USER  and ID values   #
#                                          #
# 7. Run the script!                       #
#                                          #
############################################



# Change username
USER=admin
BACKUP_DIR="/root/backups/"


if [ ! -d "${BACKUP_DIR}" ]; then
        mkdir -p ${BACKUP_DIR}
fi

cd ${BACKUP_DIR}

############################################
# Keep this structure, take care of the :  #
# Increment the "n" with a number          #
# ID[n]="RouterName:IPAddress:Port"        #
############################################ 
ID[0]="Router-A:10.0.0.1:22"
ID[1]="Router-B:192.168.1.1:22"
ID[2]="Router-C:10.1.0.1:22"

for INFO in "${ID[@]}"
do
   DATE=`date +%Y-%m-%d_%H:%M:%S`
   NAME=`echo ${INFO} |awk -F ':' '{print $1}'`
   IP=`echo ${INFO} |awk -F ':' '{print $2}'`
   PORT=`echo ${INFO} |awk -F ':' '{print $3}'`

   
||| Seguir leyendo... >>>

Proxmox 4.0-beta

El 23 de Junio salió la beta de proxmox 4.0. Esta versión trae con ella un cambio realmente grande e interesante… los contenedores vz, pasan a ser contenedores lxc!

En Proxmox Downloads, nos podemos descargar la iso de la beta.

Al instalarla por algún motivo no se dejaba porqué me soltaba “gtk-critical gtk_container_remove”, así que he leído que desconectando el cable de red la instalación seguía adelante, lo he hecho y efectivamente he podido terminar de instalar proxmox! (es importante hacer la instalación desde un disco limpio, que no haya otro proxmox, porqué tampoco se va a dejar!).

Al entrar al interfaz web, pues como siempre, la apariencia la misma, pero con algunos cambios pequeñitos que no se ven a la primera.

Lo primero que he hecho ha sido descargarme un template de openvz, así que he encontrado ésta web donde indicaban esto:

You can download this template by running the following command:
wget -P /var/lib/vz/templates/cache/ http://get.wlan0.ru/x/debian-8.0-x86_64-minimal.tar.gz

Como siempre, he creado un nuevo contenedor con éste template y una vez creado he querido entrar a él. Pero grata sorpresa! vzlist ni vzctl estaban en el sistema! y lo mas curioso, un contenedor tenía “console” en el interfaz web, así que he tratado de entrar pero simplemente no podía porque el usuario y password eran incorrectos… algo muy raro…

He empezado a investigar el sistema y en /usr/bin he visto los comandos de lxc, así que he empezado a probarlos

root@scg15:/usr/bin# ls |grep lxc
lxc-attach
lxc-autostart
lxc-cgroup
lxc-checkconfig
lxc-checkpoint
lxc-clone
||| Seguir leyendo... >>>

Proxmox 4.0-beta

El 23 de Junio salió la beta de proxmox 4.0. Esta versión trae con ella un cambio realmente grande e interesante… los contenedores vz, pasan a ser contenedores lxc!

En Proxmox Downloads, nos podemos descargar la iso de la beta.

Al instalarla por algún motivo no se dejaba porqué me soltaba “gtk-critical gtk_container_remove”, así que he leído que desconectando el cable de red la instalación seguía adelante, lo he hecho y efectivamente he podido terminar de instalar proxmox! (es importante hacer la instalación desde un disco limpio, que no haya otro proxmox, porqué tampoco se va a dejar!).

Al entrar al interfaz web, pues como siempre, la apariencia la misma, pero con algunos cambios pequeñitos que no se ven a la primera.

Lo primero que he hecho ha sido descargarme un template de openvz, así que he encontrado ésta web donde indicaban esto:

You can download this template by running the following command:
wget -P /var/lib/vz/templates/cache/ http://get.wlan0.ru/x/debian-8.0-x86_64-minimal.tar.gz

Como siempre, he creado un nuevo contenedor con éste template y una vez creado he querido entrar a él. Pero grata sorpresa! vzlist ni vzctl estaban en el sistema! y lo mas curioso, un contenedor tenía “console” en el interfaz web, así que he tratado de entrar pero simplemente no podía porque el usuario y password eran incorrectos… algo muy raro…

He empezado a investigar el sistema y en /usr/bin he visto los comandos de lxc, así que he empezado a probarlos

root@scg15:/usr/bin# ls |grep lxc
lxc-attach
lxc-autostart
lxc-cgroup
lxc-checkconfig
lxc-checkpoint
lxc-clone
||| Seguir leyendo... >>>